Вышла новая версия 1.1.22.9 типовой конфигурации 1С:Библиотека электронных документов 8.2

Версия 1.1.22

Версия 1.1.22 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • реализована система оповещений о событиях ЭДО (новые электронные документы, новые приглашения, окончание срока действия сертификата и т.д.). Появилась возможность настройки уведомлений на электронную почту в профиле настроек ЭДО, а так же вывод оповещения о событиях непосредственно в программе 1С с помощью всплывающих сообщений;
  • поддержан формат первичного документа, включающего в себя счет-фактуру (формат УПД) в соответствии с приказом Федеральной налоговой службы от 24.03.2016 № ММВ-7-15/155@ "Об утверждении формата счета-фактуры и формата представления документа об отгрузке товаров (выполнении работ), передаче имущественных прав (документа об оказании услуг), включающего в себя счет-фактуру, в электронной форме";
  • поддержан формат документа об изменении стоимости, включающего в себя корректировочный счет-фактуру" (формат УКД) в соответствии с приказом Федеральной налоговой службы от 13.04.2016 N ММВ-7-15/189@ "Об утверждении формата корректировочного счета-фактуры и формат представления документа об изменении стоимости отгруженных товаров (выполненных работ, оказанных услуг), переданных имущественных прав, включающего в себя корректировочный счет-фактуру, в электронной форме";
  • поддержаны форматы первичных документов счетов-фактур (в части передачи отдельного первичного документа, счет-фактуры) в соответствии с приказом Федеральной налоговой службы от 24.03.2016 № ММВ-7-15/155@ "Об утверждении формата счета-фактуры и формата представления документа об отгрузке товаров (выполнении работ), передаче имущественных прав (документа об оказании услуг), включающего в себя счет-фактуру, в электронной форме";
  • поддержаны форматы первичных документов об изменении стоимости, включающего в себя корректировочный счет-фактуру" (в части передачи отдельного первичного документа, корректировочного счет-фактуры) в соответствии с приказом Федеральной налоговой службы от 13.04.2016 N ММВ-7-15/189@ "Об утверждении формата корректировочного счета-фактуры и формат представления документа об изменении стоимости отгруженных товаров (выполненных работ, оказанных услуг), переданных имущественных прав, включающего в себя корректировочный счет-фактуру, в электронной форме";
  • добавлены новые электронные документы Передача товаров, Передача результатов работ, новая форма визуального представления документов;
  • добавлен механизм одностороннего обмена, не требующий извещения о получении от получателя
  • исправлены выявленные ошибки.

Переход на версию 1.1.22 с версии 1.1.20, 1.1.21

Изменения в подсистеме "Обмен с контрагентами".

Изменения в формах списков документов прикладного решения

В формах списков документов необходимо добавить подключаемую процедуру Подключаемый_ОбработчикОжиданияЭДО, в которой нужно разместить вызов метода
ЭлектронныеДокументыКлиент.ОбработчикОжиданияЭДО:

&НаКлиенте
Процедура Подключаемый_ОбработчикОжиданияЭДО()

ЭлектронныеДокументыКлиент.ОбработчикОжиданияЭДО(ЭтаФорма);

КонецПроцедуры

Если подменю ЭДО не является группой команд ЭД , то в процедуру ЭлектронныеДокументыКлиент.ОбработчикОжиданияЭДО необходимо передать элемент формы или массив элементов , который является подменю:

&НаКлиенте
Процедура Подключаемый_ОбработчикОжиданияЭДО()


ПараметрыОбработчика = ЭлектронныеДокументыКлиент.ПараметрыОбработчикаОжиданияЭДО();
ПараметрыОбработчика.ПодменюЭДО = ПодменюЭДО(Элементы);
ЭлектронныеДокументыКлиент.ОбработчикОжиданияЭДО(ЭтаФорма, ПараметрыОбработчика);

КонецПроцедуры
При обновлении подсистемы необходимо в обработчиках событий формы списка документов:
  • ПриСозданииНаСервере
  • ПриОткрытии
  • ОбработкаОповещения
разместить методы подсистемы "ЭлектронныеДокументы".
Например:
&НаСервере
Процедура ПриСозданииНаСервере

// Подсистема "Электронные документы".
ПараметрыПриСозданииНаСервере = ЭлектронныеДокументы.ПараметрыПриСозданииНаСервере_ФормаСписка();
ПараметрыПриСозданииНаСервере.Форма = ЭтаФорма;
ЭлектронныеДокументы.ПриСозданииНаСервере_ФормаСписка(Отказ, СтандартнаяОбработка, ПараметрыПриСозданииНаСервере);
// Конец подсистема "Электронные документы".
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)

// Подсистема "Электронные документы".
ЭлектронныеДокументыКлиент.ПриОткрытии(ЭтаФорма);
// Конец подсистема "Электронные документы".
КонецПроцедуры

&НаКлиенте

Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)

// Подсистема "ЭлектронныеДокументы".
ПараметрыОповещения = ЭлектронныеДокументыКлиент.ПараметрыОповешенияЭДО_ФормаСписка();
ПараметрыОповещения.Форма = ЭтаФорма;
ПараметрыОповещения.ИмяДинамическогоСписка = "СписокРеализацииТоваровУслуг";

ЭлектронныеДокументыКлиент.ОбработкаОповещения_ФормаСписка(ИмяСобытия, Параметр, Источник, ПараметрыОповещения);
// Конец подсистема "ЭлектронныеДокументы".
КонецПроцедуры

Изменения в формах документов прикладного решения:

В формах документов необходимо добавить подключаемую процедуру Подключаемый_ОбработчикОжиданияЭДО, в которой нужно разместить вызов метода
ЭлектронныеДокументыКлиент.ОбработчикОжиданияЭДО:

&НаКлиенте
Процедура Подключаемый_ОбработчикОжиданияЭДО()

ЭлектронныеДокументыКлиент.ОбработчикОжиданияЭДО(ЭтаФорма);

КонецПроцедуры

В формах документов необходимо удалить реквизит формы "СостояниеЭДО", вместо него добавить элемент формы "декорация".

При обновлении подсистемы необходимо в обработчиках событий формы документа:

  • ПриСозданииНаСервере
  • ПриОткрытии
  • ПослеЗаписиНаСервере
  • ОбработкаОповещения

разместить методы подсистемы "ЭлектронныеДокументы".
Например:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

// Подсистема "ЭлектронныеДокументы".
ПараметрыПриСозданииНаСервере = ЭлектронныеДокументы.ПараметрыПриСозданииНаСервере_ФормаДокумента();
ПараметрыПриСозданииНаСервере.Форма = ЭтаФорма;
ПараметрыПриСозданииНаСервере.ДокументСсылка = Объект.Ссылка;
ПараметрыПриСозданииНаСервере.ДекорацияСостояниеЭДО = Элементы.ДекорацияСостояниеЭДО;

ЭлектронныеДокументы.ПриСозданииНаСервере_ФормаДокумента(Отказ, СтандартнаяОбработка, ПараметрыПриСозданииНаСервере);
// Конец подсистема "ЭлектронныеДокументы".
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)

// Подсистема "ЭлектронныеДокументы".
ЭлектронныеДокументыКлиент.ПриОткрытии(ЭтаФорма);
// Конец подсистема "ЭлектронныеДокументы".
КонецПроцедуры

&НаСервере
Процедура ПослеЗаписиНаСервере(ТекущийОбъект, ПараметрыЗаписи)

// Подсистема "ЭлектронныеДокументы".
ПараметрыПослеЗаписиНаСервере = ЭлектронныеДокументы.ПараметрыПослеЗаписиНаСервере();
ПараметрыПослеЗаписиНаСервере.ДекорацияСостояниеЭДО = Элементы.ДекорацияСостояниеЭДО;
ПараметрыПослеЗаписиНаСервере.ДокументСсылка = Объект.Ссылка;

ЭлектронныеДокументы.ПослеЗаписиНаСервере(ТекущийОбъект, ПараметрыЗаписи, ПараметрыПослеЗаписиНаСервере);//ЭтаФорма, Объект.Ссылка, Элементы.ДекорацияСостояниеЭДО);
// Конец подсистема "ЭлектронныеДокументы".
КонецПроцедуры

&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)

// Подсистема "ЭлектронныеДокументы".
ПараметрыОповещенияЭДО = ЭлектронныеДокументыКлиент.ПараметрыОповешенияЭДО_ФормаДокумента();
ПараметрыОповещенияЭДО.Форма = ЭтаФорма;
ПараметрыОповещенияЭДО.ДокументСсылка = Объект.Ссылка;
ПараметрыОповещенияЭДО.ДекорацияСостояниеЭДО = Элементы.ДекорацияСостояниеЭДО;

ЭлектронныеДокументыКлиент.ОбработкаОповещения_ФормаДокумента(ИмяСобытия, Параметр, Источник, ПараметрыОповещенияЭДО);
// Конец подсистема "ЭлектронныеДокументы".
КонецПроцедуры

Изменения в модуле ЭлектронныеДокументы:

Добавлена процедура ПриСозданииНаСервере_ФормаСписка, вызывается из обработчика события "ПриСозданииНаСервере" формы списка документов. В качестве третьего параметра метода передается структура, которая инициализируется методом ПараметрыПриСозданииНаСервере_ФормаСписка.

Добавлена процедура ПриСозданииНаСервере_ФормаДокумента, вызывается из обработчика события "ПриСозданииНаСервере" формы документа. В качестве третьего параметра метода передается структура, которая инициализируется методом ПараметрыПриСозданииНаСервере_ФормаДокумента.

Добавлена процедура ПослеЗаписиНаСервере, вызывается из обработчика события "ПослеЗаписиНаСервере" формы документа. В качестве третьего параметра метода передается структура, которая инициализируется методом ПараметрыПослеЗаписиНаСервере.

Изменения в модуле ЭлектронныеДокументыКлиент:

Добавлена процедура ПриОткрытии, вызывается из обработчика события "ПриОткрытии" формы списка документов и формы документа.
Добавлена процедура ОбработкаОповещения_ФормаСписка, вызывается из обработчика события "ОбработкаОповещения" формы списка документов. В качестве четвертого параметра метода передается структура, которая инициализируется методом ПараметрыОповешенияЭДО_ФормаСписка.
Добавлена процедура ОбработкаОповещения_ФормаДокумента, вызывается из обработчика события "ОбработкаОповещения" формы документа. В качестве четвертого параметра метода передается структура, которая инициализируется методом ПараметрыОповешенияЭДО_ФормаДокумента.

Добавлена процедура ОбработчикОжиданияЭДО, вызывается из подключаемой процедуры "Подключаемый_ОбработчикОжиданияЭДО" формы списка документов и формы документа. В качестве второго параметра метода может передаваться структура, которая инициализируется методом ПараметрыОбработчикаОжиданияЭДО.

Изменения в модуле ЭлектронныеДокументыПереопределяемый:

Добавлен метод ЗаполнитьДанныеДляУПДИнформацияПродавцаФНС. Метод подготавливает данные для электронного документа типа УПД (информация продавца) функция СЧФДОП.
Добавлен метод ЗаполнитьДанныеДляУПДИнформацииПокупателяФНС. Метод подготавливает данные для электронного документа типа УПД (информация покупателя) функция СЧФДОП.
Добавлен метод НайтиСоздатьУниверсальныйПередаточныйДокумент. Метод сохраняет данные из электронного документа УПД (информация продавца) функция СЧФДОП в объекты ИБ.
Добавлен метод ЗаполнитьДанныеДляДОПИнформацияПродавцаФНС. Метод подготавливает данные для электронного документа типа УПД (информация продавца) функция ДОП.
Добавлен метод НайтиСоздатьУПДДокументОПередаче. Метод сохраняет данные из электронного документа УПД (информация продавца) функция ДОП в объект ИБ.
Добавлен метод ЗаполнитьДанныеДляСЧФИнформацияПродавцаФНС. Метод подготавливает данные для электронного документа типа УПД (информация продавца) функция СЧФ.
Добавлен метод НайтиСоздатьУПДСчетФактуру. Метод сохраняет данные из электронного документа УПД (информация продавца) функция СЧФ в объект ИБ.
Добавлен метод ЗаполнитьДанныеДляУКДИнформацияПродавцаФНС. Метод подготавливает данные для электронного документа типа УКД (информация продавца) функция КСЧФДИС.
Добавлен метод ЗаполнитьДанныеДляУКДИнформацииПокупателяФНС. Метод подготавливает данные для электронного документа типа УКД (информация покупателя) функция КСЧФДИС.
Добавлен метод НайтиСоздатьУниверсальныйКорректировочныйДокумент. Метод сохраняет данные из электронного документа УКД (информация продавца) функция КСЧФДИС в объекты ИБ.
Добавлен метод ЗаполнитьДанныеДляДИСИнформацияПродавцаФНС. Метод подготавливает данные для электронного документа типа УКД (информация продавца) функция ДИС.
Добавлен метод НайтиСоздатьУКДДокументОбИзмененииСтоимости. Метод сохраняет данные из электронного документа УКД (информация продавца) функция ДИС в объект ИБ.
Добавлен метод ЗаполнитьДанныеДляКСЧФИнформацияПродавцаФНС. Метод подготавливает данные для электронного документа типа УКД (информация продавца) функция КСЧФ.
Добавлен метод НайтиСоздатьУКДСчетФактуру. Метод сохраняет данные из электронного документа УКД (информация продавца) функция КСЧФ в объект ИБ.
Добавлен метод СоответствиеИсходящихВидовЭДДокументамИБ. Метод формирует соответствие исходящих электронных документов и документов ИБ.
Добавлен метод НайтиСоздатьДокументПередачаРезультатовРабот. Метод используется заполнения документа Товарная накладная, полученного в формате "Передача товаров".
Добавлен метод НайтиСоздатьДокументПередачаТоваров. Метод используется заполнения документа Акт об оказании услуг, полученного в формате "Передача результатов работ".

Изменения в обработке ЭлектронныеДокументы:

В макете "Торг-12Продавец":
  • добавлена табличная часть "Основание",
  • удалены поля "ДокументОснованиеНаименование", "ДокументОснованиеНомер", "ДокументОснованиеДата", "ДокументОснованиеДопСведения",
  • добавлено поле "ИдГосКонтракта",
  • добавлена табличная часть "ТранспортнаяНакладная",
  • удалены поля "ТранспортнаяНакладнаяДата", "ТранспортнаяНакладнаяНомер",
  • добавлено поле "СведенияОЛицеПередавшемТовары",
  • в свойствах участников сделки поле "Факс" заменено на поле "ЭлектроннаяПочта",
  • в свойствах участников сделки поле "КодСтр" заменено на поле "КодСтраны",
  • в свойствах участников сделки поле "АдрТекст" заменено на поле "АдресТекст".
В макете "Акт501_Исполнитель":
  • добавлена табличная часть "Основание",
  • удалены поля "ДокументОснованиеНаименование", "ДокументОснованиеНомер", "ДокументОснованиеДата", "ДокументОснованиеДопСведения",
  • добавлено поле "ВалютаНаименование",
  • добавлено поле "Претензии",
  • добавлено поле "ДатаИсполнения",
  • в свойствах участников сделки поле "Факс" заменено на поле "ЭлектроннаяПочта",
  • в свойствах участников сделки поле "КодСтр" заменено на поле "КодСтраны",
  • в свойствах участников сделки поле "АдрТекст" заменено на поле "АдресТекст".

Версия 1.1.21.7

Версия 1.1.21.7 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • в соответствии с Приказом от 30.11.2015 № ММВ-7-10/551@ "Об утверждении формата представления документа о передаче товаров при торговых операциях в электронной форме" и Приказом от 30.11.2015 № ММВ-7-10/552@ "Об утверждении формата представления документа о передаче результатов работ (документа об оказании услуг) в электронной форме" поддержаны новые форматы электронных документов;
  • реализовано отображение 2-х титулов электронных документов (ТОРГ12, Акт, Корректировочные документы) в единой форме просмотра электронного документа. Вся информация из титулов будет собрана на единую форму. Отдельно форму второго титула можно будет посмотреть из формы "Электронный документы";
  • реализована возможность заключать типовое "Соглашение об ЭДО" в электронном виде из "Настройки ЭДО" в программе 1С; По команде "Сформировать соглашение по шаблону" автоматически будет создан произвольный электронный документ, вложением которого будет файл соглашения. После подписания документ можно будет сразу отправить контрагенту.
  • интегрирован обмен произвольными электронными документами с присоединенными файлами. Теперь любой присоединенный файл можно быстро подписать и отправить контрагенту с помощью произвольного электронного документа;
  • исправлены выявленные ошибки.

Переход на версию 1.1.21.7 с версии 1.1.19.4, 1.1.20.5

Изменения в подсистеме "Обмен с контрагентами".

В модуле ЭлектронныеДокументыПереопределяемый внести изменение:

// Подготавливает данные для электронного документа типа ТоварнаяНакладная.
//
// Параметры:
// СсылкаНаЭД - Ссылка на ЭД, по которому необходимо сформировать электронный документ,
// СтруктураЭД - Структура, структура данных для формирования электронного документа.
// ДеревоДанных - дерево значений, дерево данных заполнения электронного документа.
//
Процедура ЗаполнитьДанныеПередачаТоваровПродавец(СсылкаНаОбъект, СтруктураЭД, ДеревоДанных) Экспорт
ЗаполнитьДанныеПоТорг12ПродавецФНС(СсылкаНаОбъект, СтруктураЭД, ДеревоДанных)
КонецПроцедуры

// Подготавливает данные для электронного документа типа Акт об оказанных услугах.
//
// Параметры:
// СсылкаНаЭД - Ссылка на ЭД, по которому необходимо сформировать электронный документ,
// СтруктураЭД - Структура, структура данных для формирования электронного документа.
// ДеревоДанных - Дерево значений, дерево данных заполнения электронного документа.
//
Процедура ЗаполнитьДанныеПередачаРаботИсполнитель(СсылкаНаОбъект, СтруктураЭД, ДеревоДанных) Экспорт
ЗаполнитьДанныеПоАкт501ИсполнительФНС(СсылкаНаОбъект, СтруктураЭД, ДеревоДанных)
КонецПроцедуры

Изменения реквизита произвольного электронного документа ДокументОснование:

Необходимо указать какие документы будут являться основанием. Как правило это все документы, на основании которых формируются формализванные электронные документы.

Изменения типа параметра общей команды СтруктураПодчиненности:

Отметить Произвольный документ.

Изменения состава критерия отбора СвязанныеДокументы:

Добавить Документ.ПроизвольныйЭД.Реквизит.ДокументОснование.

Версия 1.1.21.7

Версия 1.1.20.5

Версия 1.1.20.5 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • реализована возможность быстрого подключения к сервису 1С-ЭДО по гиперссылке в блоке ЭДО на формах документов информационной базы;
  • добавлена колонка на форме списка (форме выбора) справочника "Контрагенты" с отображением признака подключенности контрагента к сервису 1С-ЭДО;
  • исправлены выявленные ошибки.

Переход на версию 1.1.20.5 с версии 1.1.18.6, 1.1.19.4

В макетах АктНаПередачуПрав, ЗаказТовара, ОтветНаЗаказ, ОтчетКомиссионераОПродажах, ОтчетКомиссионераОСписании, СчетНаОплату, КаталогТоваров, ПрайсЛист в группе параметров "Банк" у поле "БИК" изменен признак обязательного заполнения. Необходимо предусмотреть заполнение данного поля;

Изменения в модуле ЭлектронныеДокументыПереопределяемый:

В метод ПолучитьСоответствиеНаименованийОбъектовМДиРеквизитов добавлены для переопределения два ключа:
  • РеализацияТоваровУслугВМетаданных
  • ПоступлениеТоваровУслугВМетаданных

Изменения в модуле ЭлектронныеДокументы:

Добавлен метод ПроверитьКонтрагентаВ1СЭДОПриСозданииНаСервере, который необходимо вызвать при создании формы контрагента. Данный метод запускает проверку на подключение контрагента к сервису 1С-ЭДО.

Пример ЭлектронныеДокументы.ПроверитьКонтрагентаВ1СЭДОПриСозданииНаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
// ЭлектронноеВзаимодействие.ОбменСКонтрагентами
ЭлектронныеДокументы.ПроверитьКонтрагентаВ1СЭДОПриСозданииНаСервере(Объект.Ссылка);
// Конец ЭлектронноеВзаимодействие.ОбменСКонтрагентами
КонецПроцедуры

Добавлено НЕ разделенное регламентное задание ПроверкаКонтрагентовБЭД, которое делает выборку контрагентов и выполняет по ним проверку подключения к 1С-ЭДО.

Добавлен разделенный регистр сведений СостоянияКонтрагентовБЭД, в котором собирается статистика по подключенным контрагентам к сервису 1С-ЭДО.

Добавить вывод признака подключения к сервису 1С-ЭДО в колонку "ЭДО" на форме списка и форме выбора контрагентов. Добавить подсказку к колонке "Подключен к сервису 1С-ЭДО".

Пример
"ВЫБРАТЬ
ВЫБОР
КОГДА СостоянияКонтрагентовБЭД.Состояние = ЗНАЧЕНИЕ(Перечисление.СостоянияКонтрагентаБЭД.Подключен)
ТОГДА 0
ИНАЧЕ 1
КОНЕЦ
КОНЕЦ КАК ЭДО,
СправочникКонтрагенты.Наименование,
СправочникКонтрагенты.ИНН,
СправочникКонтрагенты.КПП,
....
СправочникКонтрагенты.НаименованиеПолное
ИЗ
Справочник.Контрагенты КАК СправочникКонтрагенты
ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.СостоянияКонтрагентовБЭД КАК СостоянияКонтрагентовБЭД
ПО (СостоянияКонтрагентовБЭД.Контрагент = СправочникКонтрагенты.Ссылка)"

На формах документов информационной базы убрать привязку к функциональной опции "ИспользоватьОбменЭД" у реквизита формы "ТекстСостоянияЭД". Удалить заголовок у реквизита "Состояние ЭД".

Версия 1.1.19.4

Версия 1.1.19.4 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • упрощен интерфейс пользователя по работе с формой просмотра электронного документа и командами ЭДО;
  • расширен функционал по работе с приглашениями в 1С-ЭДО;
  • исправлены выявленные ошибки.

Переход на версию 1.1.19.4 с версии 1.1.17.6, 1.1.18.6

Версия 1.1.18.6

Версия 1.1.18.6 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • в соответствии с Приказом ФНС РФ от 02.02.2015 № ММВ-7-15/40@ "Об утверждении форматов счета-фактуры, журнала учета полученных и выставленных счетов-фактур, книги покупок и книги продаж, дополнительных листов книги покупок и книги продаж в электронной форме" обновлены форматы документов "Счет-фактура" и "Корректировочный счет-фактура";
  • в соответствии с Приказом ФНС РФ от 04.03.2015 № ММВ-7-6/93@ "О внесении изменений в приказ ФНС России от 21.03.2012 № ММВ-7-6/172@" обновлены форматы документов "ТОРГ12" и "Акта приемки-сдачи работ (услуг)";
  • исправлены выявленные ошибки

Переход на версию 1.1.18.6 с версии 1.1.16.10, 1.1.17.6

Версия 1.1.17.6

Версия 1.1.17.6 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • реализовано подключение и обмен электронными документами через сервис 1С-ЭДО. Теперь появилась возможность обмениваться электронными документами через оператора ЭДО "Калуга Астрал";
  • в форме просмотра эл.документа добавлено визуальное представление дополнительных данных передаваемых вместе с электронными документами форма CML 2.08 (заказ покупателя, заказ поставщику, счет на оплату и т.д.);
  • исправлены выявленные ошибки.

Переход на версию 1.1.17.6 с версии 1.1.15.13, 1.1.16.10

В макетах АктНаПередачуПрав, ЗаказТовара, ОтветНаЗаказ, ОтчетКомиссионераОПродажах, ОтчетКомиссионераОСписании,
СчетНаОплату в группу "ДопДанные" добавлено поле "НеПодписанные".
В макетах КаталогТоваров, ПрайсЛист добавлена группа "ДопДанные.НеПодписанные".

При заполнении выше указанных параметров в переопределяемой части, значения будут передаваться вместе с электронным документом с помощью мехнизма передачи доп. данных. Взависимости от группы "Подписанные" или "НеПодписанные" данные будет передавать внутри эл.документа или же отдельным файлом.

Версия 1.1.16.10

Версия 1.1.16.10 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • поддержан механизм аннулирования эл.документов (кроме ЭСФ);
  • добавлена возможность передавать доп.данные для эл.документов в формате CML;
  • реализована возможность оставлять "комментарии" по эл.документу (для внутреннего использования), а также заполнять "сопроводительную записку" (для отправки получателю);
  • поддержан обмен исправительным "Актом на передачу прав" в эл. виде;
  • реализована единая форма "карточки" эл.документа, в т.ч и для "Произвольного эл.документа", с возможностью предпросмотра перед печатью;
  • для удобства маршрутизации эл.документов добавлена команда "Направить на рассмотрение" (для операций утверждения, подписания и пр.);
  • реализован быстрый переход в список эл.документов с позиционированием на текущем элементе из наиболее часто используемых форм: форма просмотра эл.документа, "Текущие дела ЭДО", "Архив ЭДО";
  • в ЭСФ переименована команда "Отклонить электронный документ" в "Запросить уточнение по электронному документу";
  • исправлены выявленные ошибки.

Переход на версию 1.1.16.10 с версии 1.1.14.4, 1.1.15.11, 1.1.15.13

В макете АктНаПередачуПрав добавлены поля:

  • ВидОперации;
  • НомерИсправления;
  • ДатаИсправления;
Заполняются при формировании Исправительного и Корректировочного акта на передачу прав.
  • ДокументыСделки, заполняется таблица данными по документам сделки(договор, дата и номер платежного поручения);
  • ДопДанные.Подписанные, заполняются при передаче доп. данных шапки документа информациионной базы;
  • Товары.СерийныеНомера
  • Товары.ДокументОснования, заполняется при передаче документов оснований в табличной части документа информациионной базы.
  • Товары.ДопДанныеПодписанные, заполняется при передаче доп. данных табличной части документа информациионной базы.
Изменены поля:
Поле ДокументыОснования вместо таблицы значений имет тип Ссылка или МассивСсылок.

В макете ЗаказТовара добавлены поля:

  • ДоговорНомер;
  • ДоговорДата;
  • РасчетныйСчет;
  • ДокументыОснования, заполняется при передаче документов оснований шапки документа информациионной базы.
  • ДопДанные.Подписанные, заполняются при передаче доп. данных шапки документа информациионной базы;
  • Товары.ДокументОснования, заполняется при передаче документов оснований в табличной части документа информациионной базы;
  • Товары.ДопДанныеПодписанные, заполняется при передаче доп. данных табличной части документа информациионной базы.

В макете КаталогТоваров добавлены поля:

  • Товары.ДопДанныеПодписанные, заполняется при передаче доп. данных табличной части документа информациионной базы.

В макете ОтветНаЗаказ добавлены поля:

  • ДоговорНомер;
  • ДоговорДата;
  • РасчетныйСчет;
  • ДокументыОснования, заполняется при передаче документов оснований шапки документа информациионной базы.
  • ДопДанные.Подписанные, заполняются при передаче доп. данных шапки документа информациионной базы;
  • Товары.ДокументОснования, заполняется при передаче документов оснований в табличной части документа информациионной базы;
  • Товары.ДопДанныеПодписанные, заполняется при передаче доп. данных табличной части документа информациионной базы.

В макете ОтчетКомиссионераОПродажах добавлены поля:

  • ДопДанные.Подписанные, заполняются при передаче доп. данных шапки документа информациионной базы;
  • Товары.ДопДанныеПодписанные, заполняется при передаче доп. данных табличной части документа информациионной базы.

В макете ОтчетКомиссионераОСписании добавлены поля:

  • ДопДанные.Подписанные, заполняются при передаче доп. данных шапки документа информациионной базы;
  • Товары.ДопДанныеПодписанные, заполняется при передаче доп. данных табличной части документа информациионной базы.

В макете ПрайсЛист добавлены поля:

  • Товары.ДопДанныеПодписанные, заполняется при передаче доп. данных табличной части документа информациионной базы.

В макете СчетНаОплату добавлены поля:

  • ДокументыОснования, заполняется при передаче документов оснований шапки документа информациионной базы.
  • ДопДанные.Подписанные, заполняются при передаче доп. данных шапки документа информациионной базы;
  • Товары.ДокументОснования, заполняется при передаче документов оснований в табличной части документа информациионной базы;
  • Товары.ДопДанныеПодписанные, заполняется при передаче доп. данных табличной части документа информациионной базы.

Во всех макетах ЭД(кроме вторых титулов): добавлено поле СопроводительнаяЗаписка.

При подготовке данных в модуле ЭлектронныеДокументыПереопределяемый в поле СопроводительнаяЗаписка можно записывать программно сформированное сообщение для получателя электронного документа.

Версия 1.1.15.13

Версия 1.1.15.3 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

Исправлены выявленные ошибки.

Версия 1.1.15.11

Версия 1.1.15.11 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • поддержано изменение размерности кодов единиц измерений - "Изменение N 8/2013 Общероссийский классификатор единиц измерения (ОКЕИ) ОК 015-94 (МК 002-97)"(утв. Приказом Росстандарта от 26.09.2013 N 1101-ст);
  • реализована возможность хранения пароля к закрытой части ключа электронной подписи на время работы клиентского сеанса;
  • добавлено автоматическое определение необходимости формирования ответной подписи на электронном документе (если входящий электронный документ был подписан, то в ответ требуется также подписать электронный документ);
  • добавлен тест настроек сертификата электронной подписи для прямого обмена с контрагентами;
  • добавлена возможность отслеживать "приглашения к обмену" в обработке "Текущий дела ЭДО";
  • реализован вывод причины отклонения электронного документа в список элементов группировок "Обработать" и "Уточнить" формы "Текущие дела ЭДО";
  • добавлена возможность запросить уточнение по электронному документу при прямом обмене с контрагентом;
  • добавлена возможность выбора формата версии для видов электронных документов, обмен которыми возможен по разным версиям XML-формата;
  • реализовано создание "Настроек ЭДО" по входящим "приглашениям к обмену" от контрагента;
  • реализовано получение актуальных статусов и отправка приглашений при обмене через оператора ЭДО по команде "Отправить и получить электронные документы", а также через регламентные задания;
  • для более гибкого использования настроек ЭДО в рамках обмена с одним контрагентом добавлена возможность указать "Договор контрагента";
  • добавлена возможность подключать контрагентов прямо из формы элемента справочника "Контрагенты", а также из документа-основания информационной базы;
  • добавлена возможность работы с функционалом электронных документов в режиме "только просмотр" по закрытой настройке ЭДО;
  • добавлена возможность принудительного прекращения ЭДО из обработки "Текущие дела ЭДО";
  • оптимизирован порядок записи в системный журнал регистрации по событиям ЭДО для удобной фильтрации;
  • переработан поиск документов-оснований для электронных счетов-фактур при комиссионной торговле;
  • исправлены выявленные ошибки.

Переход на версию 1.1.15.11 с версии 1.1.13.7, 1.1.14.3, 1.1.14.4.

Добавлен новый справочник Профили настроек ЭДО.

Помечен к удалению регистр сведений УдалитьУчастникиОбменовЭДЧерезОператоровЭДО.

В общем модуле ЭлектронныеДокументыПереопределяемый:

В методе ЗаполнитьПараметрыЭДПоИсточнику необходимо добавить заполнение договора контрагента.
Добавлены новые методы:
  • заполнитьСоответствиеСтавокНДС, в котором необходимо опеределить соотвествие ставок НДС прикладного решения;
  • дополнительнаяАналитикаСправочникХарактеристикиНоменклатуры, который определяет использование характеристик номенклатуры в прикладном решении;
  • ПолучитьСтавкуНДСЧислом;
  • ЗначениеПеречисленияСтавкаНДС;
  • ПолучитьТекстНастроекОбменаПоСоглашению;
  • ПолучитьТекстЗапросаНастроекОбменаСПриоритетами;
Метод ПолучитьСоответствиеСтавокНДС заменен на метод ЗаполнитьСоответствиеСтавокНДС;
3.Дополнить соответствие в методе ПолучитьСоответствиеСправочников:
СоответствиеСправочников.Вставить("ДоговорыКонтрагентов", "");

5.
Дополнить соответствие в методе ПолучитьСоответствиеНаименованийОбъектовМДиРеквизитов:
СоответствиеРеквизитовОбъекта.Вставить("ИННКонтрагента", "");
СоответствиеРеквизитовОбъекта.Вставить("КППКонтрагента", "");
СоответствиеРеквизитовОбъекта.Вставить("НаименованиеКонтрагента", "");
СоответствиеРеквизитовОбъекта.Вставить("НаименованиеКонтрагентаДляСообщенияПользователю", "");
СоответствиеРеквизитовОбъекта.Вставить("ВнешнийКодКонтрагента", "");
СоответствиеРеквизитовОбъекта.Вставить("ПартнерКонтрагента", "");
СоответствиеРеквизитовОбъекта.Вставить("ИННОрганизации", "");
СоответствиеРеквизитовОбъекта.Вставить("КППОрганизации", "");
СоответствиеРеквизитовОбъекта.Вставить("НаименованиеОрганизации", "");
СоответствиеРеквизитовОбъекта.Вставить("СокращенноеНаименованиеОрганизации", "");

В макетах СчетФактура и КорректировочныйСчетФактура добавлен: блок данных "Комиссионер".

При выставлении счета-фактуры Комитентом Комиссионеру в Организацию помещаются данные Комитента, в Контрагента - данные Покупателя, в Комиссионера - данные Комиссионера. При разборе счета-фактуры на стороне получателя данные Организации помещаются в дерево разбора в блок Контрагент, данные Покупателя - в блок Покупатель, данные коммисионера - в блок Организация.
Устанавливается признак "ВыставленКомитентом“ (принимающий значение Истина если в ЭД присутствуют данные Комиссионера, в противном случае – Ложь);

Во всех макетах ЭД: тип параметра "Ставка НДС" изменился на ссылочный тип.

При подготовке данных в качестве ставки НДС требуется указывать прикладное значение ставки (перечисление-ссылка или справочник-ссылка), далее при заполнении данных ЭД, БЭД преобразует полученный параметр в нужное значение;

В общем модуле ОбновлениеИнформационнойБазыЭД:

Обращаем внимание на обработчик обновления ЗаполнитьДанныеОПрофиляхНастроекЭДО:
1. Создаются элементы справочника "Профили настроек ЭДО";
2. Заполняются данными новые параметры настроек прямого обмена (удаляет дубли);
3. Создаются элементы справочника "Настройки ЭДО" со способ обмена "через оператора ЭДО" по записям регистра сведений "УчастникиОбменовЭДЧерезОператоровЭДО";
"Соглашения ЭД" со статусом не равным "Действует" помечает на удаление;
4. Заполняются соответствующие реквизиты в элементах справочника "ЭДПрисоедименныеФайлы" актуальными профилем настроек ЭДО и настройкой ЭДО.

Версия 1.1.14.4

Версия 1.1.14.4 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • Исправлены выявленные ошибки.

Версия 1.1.14.3

Версия 1.1.14.3 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • реализована новая технология прямого взаимодействия с банками из решений 1С через внешнюю обработку;
  • поддержана возможность прямого обмена платежными документами с банками, подключенных к системе "iBank 2", по технологии обмена через внешнюю обработку;
  • реализована новая технология прямого взаимодействия с банками из решений 1С по логину и паролю клиента (без использования эл.подписи на стороне 1С);
  • при отправке каталога товаров для прямого обмена между Продавцом и Покупателем появилось возможность передавать свойства номенклатуры, любое количество штрихкодов, изображения товара и граф.представление сертификатов качества;
  • для произвольных эл.документов добавлена возможность "Ввода на основании" (как для входящих, так и исходящих). Такая возможность позволяет "увязывать" произвольные эл.документы в смысловые цепочки и просматривать связанные эл.документы через структуру подчиненности;
  • переработана форма "Произвольного эл.документа":
а) добавлена возможность задать "тип" передаваемого документа (выбор из предопределенного списка значений);
б) на стороне Отправителя появилась возможность управлять в явном виде требованием ответной подписи Получателя;
в) на форму выведены установленные подписи и статусы эл.документа;
г) для вложения добавлены возможности замены файла и установки любого количества эл.подписей перед отправкой;
  • для удобства поиска в список произвольных эл.документов добавлены колонки "Тип документа" и "Сопроводительная записка к вложению" (первые 100 символов текста);
  • для произвольных эл.документов появилась возможность работать из форм "Текущие дела по ЭДО" (подписывать и отправлять, контролировать получение ответной подписи) и "Документы на подпись" (подписывать и отправлять);
  • реализован функционал отклонения произвольного эл.документа в явном виде с обязательным указанием причины (как на стороне Отправителя, так и на стороне Получателя);
  • поддержана возможность передать доп.параметры (вид, номер, дата) по "документу сделки" (договор, заказ товара, оплата и т.д.) для формализованным эл.документов "ТОРГ-12", "Акт выполненных работ (оказанных услуг)", "Счет-фактура";
  • исправлены выявленные ошибки.

Переход на версию 1.1.14.3 с версии 1.1.13.7.

Переход на версию 1.1.14.3 с версии 1.1.13.7

В общем модуле ОбменССайтомПереопределяемый:

  • Добавлена процедура "ДополнитьПараметрыПрикладногоРешения" которая позволяет добавлять произвольные параметры в структуру обмена с сайтом
  • Процедура "ПолучитьТекстЗапросаКаталог" заменена не процедуру "ПолучитьТекстыЗапросовКаталог"
  • Процедура "ПолучитьТекстЗапросаПакетПредложений" заменена на процедуру "ПолучитьТекстыЗапросовПакетаПредложений"

Изменения в обработке ЭлектронныеДокументы:

  • в макет СчетФактура добавлено поле ВидСчетаФактуры
  • в макеты ТОРГ-12_Продавец, Акт501_Исполнитель, СчетФактура добавлены поля ДокументСделкиНаименование, ДокументСделкиНомер, ДокументСделкиДата
  • в макет АктНаПередачуПрав добавлено поле СерийныйНомер
  • в макеты КаталогТоваров, АктНаПередачуПрав добавлены поля Свойства, Штрихкоды, ПрисоединенныеФайлы

Версия 1.1.13.7

Версия 1.1.13.7 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • расширен перечень поддерживаемых видов электронных документов для однократной сделки;
  • повышена скорость и надежность обмена данными с CMS для большого ассортиментного перечня продукции;
  • реализован функционал передачи данных по остаткам товаров на складах и информации по "пунктам самовывоза" на сайт;
  • доработана возможность управлять в пользовательском режиме типом выгрузки данных (каталог товаров, пакет предложений, обновление пакета предложений) и составом свойств номенклатуры, передаваемых на сайт;
  • исправлены выявленные ошибки.

Переход на версию 1.1.13.7 с версий 1.1.11.3, 1.1.12.3.

Изменения в обработке ЭлектронныеДокументы:

Добавлены макеты:

  • СчетФактура;
  • КорректировочныйСчетФактура;
  • ИзвещениеОПолучении;
  • УведомлениеОбУточнении.

Изменения в модуле ЭлектронныеДокументыПереопределяемый:

Добавлена процедура ЗаполнитьДанныеПоСчетуФактуреФНС по заполнению дерева значений данными для формирования электронного документа с видом "счет-фактура";
Добавлена процедура ЗаполнитьДанныеПоКорректировочномуСчетуФактуреФНС по заполнению дерева значений данными для формирования электронного документа с видом "корректировочный счет-фактура.

Версия 1.1.12.3

Версия 1.1.12.3 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • внесены изменения в представления электронных документов: "ТОРГ-12" и "Соглашение об изменении стоимости";
  • реализована выгрузка электронных документов в файлы для отправки в ФНС через сервис "1С-Отчетность";
  • исправлены выявленные ошибки.

Переход на версию 1.1.12.3 с версий 1.1.10.7, 1.1.11.3.

Изменения в обработке ЭлектронныеДокументы:

Добавлена новая форма ФормаВыбораЭДДляПередачиФНСЧерезОтчетность для подбора ЭД для выгрузки в файлы и отправки в ФНС через сервис "1С-Отчетность". Вызов новой формы осуществляется из формы "АрхивЭДО".
В макете СоглашениеОбИзмененииСтоимостиОтправитель добавлены поля для заполнения:
  • НомерИсправления;
  • ДатаИсправления;
  • НомерИсходногоДокумента;
  • ДатаИсходногоДокумента;
  • ПредставлениеИсходногоДокумента;
  • НомерИсправленияИсходногоДокумента;
  • ДатаИсправленияИсходногоДокумента.
В макете ТОРГ12_Продавец, Акт501_Исполнитель добавлены поля для заполнения:
  • НомерИсправления;
  • ДатаИсправления.

Изменения в модуле ЭлектронныеДокументыПереопределяемый:

Добавлена процедура ПолучитьНомерДатаДоговораДокументов для получения номера и даты документов оснований (договоров) по массиву ссылок.

Версия 1.1.11.3

Версия 1.1.11.3 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • актуализированы схемы электронных документов "Счет-фактура" и "Корректировочный счет-фактура" в связи с изменениями приложений от 01.08.2013 к приказу ФНС России от 05.03.2012 № ММВ-7-6/138@58.911.00.500.001;
  • обновлены подсистемы "Библиотеки стандартных подсистем" (БСП) до версии 2.1.6.2;
  • исправлены выявленные ошибки.

Версия 1.1.10.7

Версия 1.1.10.7 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • поддержана работа с квалифицированными сертификатами электронной подписи согласно федерального закона Российской Федерации от 6 апреля 2011 г. N 63-ФЗ "Об электронной подписи";
  • обновлены подсистемы "Библиотеки стандартных подсистем" (БСП) до версии 2.1.6.1;
  • исправлены выявленные ошибки.

Переход на версию 1.1.10.7 с версий 1.1.8.3, 1.1.9.4.

ВАЖНО!
Изменения в модуле ЭлектроннаяПодписьКлиентСервер подсистемы БСП ЭлектроннаяПодпись:

В методе ПолучитьПредставлениеПользователя внести следующие изменения:
Заменить код: Представление = CN; На код: Представление = Строка(CN);
Заменить код: Представление = SN; На код: Представление = Строка(SN);

Изменения в обработке ЭлектронныеДокументы:

В слудующих макетах удалены строки о Подписанте для заполнения:
- СоглашениеОбИзмененииСтоимостиОтправитель;
- СоглашениеОбИзмененииСтоимостиПолучатель;
- ТОРГ12_Продавец;
- ТОРГ12_Покупатель;
- Акт501_Исполнитель;
- Акт501_Заказчик.

Изменения в модуле ЭлектронныеДокументыПереопределяемый:

Необходимо убрать заполнение данных о подписанте в дереве в следующих методах:
- ЗаполнитьДанныеПоКорректировочномуДокументу;
- ЗаполнитьДанныеПоКорректировочномуДокументуПолучатель;
- ЗаполнитьДанныеПоТорг12ПродавецФНС;
- ЗаполнитьДанныеПоТОРГ12ПокупательФНС;
- ЗаполнитьДанныеПоАкт501ИсполнительФНС;
- ЗаполнитьДанныеПоАкт501ЗаказчикФНС.

Изменения в справочнике СертификатыЭП.

Добавлен реквизит ДолжностьПоСертификату.
Реализовано автоматическое заполнение реквизитов: Фамилия, Имя, Отчество, ДолжностьПоСертификату из данных сертификата при условии использования версии платформы 8.2.18.109 и выше.

Версия 1.1.9.4

Версия 1.1.9.4 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • разработан инструмент пользователя для мониторинга состояния ЭДО и возможности повлиять на продвижение электронных документов по регламенту обмена;
  • добавлена возможность обмениваться документом "Акт на передачу прав" в электронном виде;
  • обновлены подсистемы "Библиотеки стандартных подсистем" (БСП) до версии 2.1.4.25;
  • актуализована терминология по 63-ФЗ в части сертификатов электронных подписей;
  • оптимизирована работа с соглашениями по обмену электронными документами через оператора ЭДО;
  • улучшена форму ввода пароля к закрытой части ключа сертификата подписи;
  • исправлены выявленные ошибки.

Переход на версию 1.1.9.4 с версий 1.1.7.5, 1.1.8.3.

Справочник Партнеры переименован в _ДемоПартнеры. Все обращения к данному справочнику вынесены в модуль ЭлектронныеДокументыПереопределяемый.

Изменения в модуле ЭлектронныеДокументыПереопределяемый:

Добавлен метод ПриИзмененииПрисоединенногоФайла. Данное событие возникает при изменении элемента справочника ЭДПрисоединенныеФайлы. Метод предназначен для переопределения или добавления изменяемых реквизитов электронного документа.
Добавлен метод ПодготовитьДанныеПоАктуНаПередачуПрав. Заполняет данные для электронного документа типа Акт на передачу прав.
Добавлен метод ДополнительнаяАналитикаКонтрагентовСправочникПартнеры. Метод переопределяет признак использования дополнительной аналитики справочника Партнеры у справочника Контрагенты. При использовании дополнительной аналитики(справочник Партнеры) необходимо обеспечить поиск ссылок на элементы в справочнике Партнеры в методе НайтиСсылкуНаОбъект. В общей команде СоглашенияОбИспользованииЭДСОтбором указать в типе параметра команды справочник Партнеры.

Удален реквизит Партнер на форме элемента справочника СоглашенияОбОбменеЭД.

Добавлена новая обработка ТекущиеДелаПоЭДО. Отдельное рабочее место для управления электронными документами.

Возможности рабочего места:

  • групповая обработка списка документов информационной базы, которые находятся в "промежуточном состоянии" и для которых необходимы дальнейшие действия;
  • отбор документов "в работе" по исполнителю;
  • электронные документы, полученные через оператора ЭДО Такском, которые не удается прочитать, сохраняются в неизменном виде в документе ПакетЭД, чтобы пользователь мог вручную разобрать документ;
  • неизвестные документы выводятся в специальном списке с возможностью пометки отработанного документа;
  • создается отчет в виде диаграммы, показывающий общее состояние ЭДО. В отчете предусмотрен выбор интервала времени.

Версия 1.1.8.3

Версия 1.1.8.3 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • добавлена подсистема "Обмен с сайтами". С помощью новой подсистемы учетная система может быть интегрирована с одним или несколькими интернет-магазинами: на сайт выгружается справочная информация о товарах с ценами, а в учетную систему загружаются заказы, оформленные в интернет-магазине. Периодичность обмена задается в настройках подсистемы в режиме "1С:Предприятия". Для интеграции используется открытый протокол обмена данными с сайтом;
  • обновлены подсистемы "Библиотеки стандартных подсистем" (БСП) до версии 2.1.4.18;
  • исправлены выявленные ошибки.

Переход на версию 1.1.8.3 с версий 1.1.6.5, 1.1.7.5.

Изменения в модуле ЭлектронныеДокументыПереопределяемый:

Добавлен обязательный параметр Организация в метод ДолжностьПодписанта.

Изменения в модуле ЭлектронныеДокументыКлиентПереопределяемый:

Добавлена процедура ОткрытьФормуСопоставленияНоменклатуры для назначения специальной формы выбора номенклатуры для сопоставления.

Добавлено использование новой функциональной опции "Базовая".

Версия 1.1.7.5

Версия 1.1.7.5 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • добавлена возможность регистрации нескольких сертификатов ЭЦП в одном "Соглашении об использовании электронных документов" через оператора ЭДО;
  • реализован контроль обязательной регистрации в сервисе оператора ЭДО сертификата ЭЦП, используемого для подписания всех электронных документов при обмене через оператора ЭДО;
  • пакет электронных документов для разных вариантов обмена (обмен по однократной сделке, прямой обмен между контрагентами, обмен через оператора ЭДО) приведен к единому формату;
  • добавлено детальное информирование пользователя о состоянии процесса отправки и получения электронных документов;
  • процесс выгрузки электронных документов по однократной сделке реализован в асинхронном режиме, при котором пользователь может продолжать работать в программе, не дожидаясь окончания завершения процесса выгрузки;
  • обновлены подсистемы "Библиотеки стандартных подсистем" (БСП) до версии 2.1.3.50;
  • исправлены выявленные ошибки.

Переход на версию 1.1.7.5 с версий 1.1.5.1, 1.1.6.5.

Изменения в модуле ЭлектронныеДокументыПереопределяемый:

Процедура ДолжностьПодписанта добавлена.
Процедура ПолучитьТекстЗапросаНастроекОбменаСПриоритетами и ПолучитьТекстНастроекОбменаПоСоглашению изменены. Изменения связаны с переименованием табличной части справочника "СоглашенияОбИспользованииЭД": старое имя – "СертификатыНеобходимыхПодписей", новое – "СертификатыПодписейОрганизации". В текстах указанных запросов необходимо выполнить замену с учётом описанных изменений.

Изменения в модуле ЭлектронныеДокументы:

Процедура ДатаВыставленияСчетФактуры добавлена.

Изменения в модуле ОбновлениеИнформационнойБазыЭД:

Добавлена процедура-обработчик обновления ПеренестиСертификатАвторизацииВТЧ для версии 1.1.7.1, которая переносит сертификат ЭП из реквизита "Сертификат авторизации" в табличную часть "СертификатыПодписейОрганизации".
Добавлена процедура-обработчик обновления ЗаполнитьВерсииФорматовИсходящихЭДИПакета для версии 1.1.7.4, которая производит заполнение версии формата в табличной части ИсходящиеДокументы.

Добавлена новое перечисление ВерсииФорматаПакетаЭД для определения версии формата пакета ЭД в случае прямого обмена.

На форме "Соглашения с контрагентом об использовании электронных документов (прямой обмен)" на закладке "Форматы исходящих документов" добавлена возможность выбора версии формата пакета электронных документов.

Добавлены новые общие модули перечисление ДлительныеОперации, ДлительныеОперацииКлиент, ДлительныеОперацииКлиентПовтИсп в подсистему БазоваяФункциональность.

Версия 1.1.6.5

Версия 1.1.6.5 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • Обновлены подсистемы "Библиотеки стандартных подсистем" (БСП) до версии 2.1.3.39.
  • Исправлены выявленные ошибки.

Версия 1.1.6.3

Версия 1.1.6.3 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • Добавлена новая подсистема "СбербанкОнлайн" (бета-версия подсистемы), которая включает в себя функционал прямого взаимодействия со Сбербанком России для отправки платежных поручений в банк и получения выписок банка из интерфейса решений 1С, минуя программы клиент-банка.
  • Добавлена возможность выгружать электронный документ "Каталог товаров" на локальный диск или отправлять по электронной почте для однократных сделок.
  • Добавлена возможность загружать электронный документ "Каталог товаров" для однократных сделок.
  • Добавлена возможность в соглашениях прямого обмена с контрагентом для вида электронного документа "Каталог товаров" выбрать версию формата.
  • Исправлены выявленные ошибки.

Переход на версию 1.1.6.3 с версий 1.1.4.2, 1.1.5.1.

В этом разделе даны дополнительные сведения, которые требуется учесть при обновлении с версий 1.1.4.2, 1.1.5.1 на версию 1.1.6.3.

Добавлена подсистема СбербанкОнлайн, которая подчинена подсистеме ОбменСБанками.

Добавлена новая схема XDTO CML 2.06.

Изменения в модуле ЭлектронныеДокументыПереопределяемый:

Процедура ПолучитьНомераБанковскихСчетов добавлена.
Процедура ПроверитьИспользованиеПодсистемыСбербанк добавлена.
Процедура ПодготовитьДанныеПоКаталогуТоваровCML добавлена. Необходимо обеспечить заполнение дерева значений для формирования ЭД по схеме CML 2.06.

На форме "Соглашение с банком об обмене электронными документами (прямой обмен)" добавлено поле выбора программы банка.

На форме "Соглашения с контрагентом об использовании электронных документов (прямой обмен)" добавлена возможность выбора версии формата для вида документа "Каталог товаров".

В форме списка справочника "Сертификаты ЭЦП" добавлена команда "Загрузить сертификат с токена банка" для загрузки сертификата Сбербанка.

Добавлена общая команда "Выгрузить каталог в файл" для выгрузки электронного документа "Каталог товаров".

Изменения в обработке ЭлектронныеДокументы:

Макет CML206_Каталог добавлен;
Макет КарточкаПередаваемыхДанныхТакском добавлен;
Макет ТранспортнаяИнформацияТакском добавлен;

Изменения в модуле ОбновлениеИнформационнойБазыЭД:

Добавлена процедура-обработчик обновления ОбработатьВерсииФорматовВСоглашениях для версии 1.1.6.3, которая проставляет версию формата CML 4.02 во всех непомеченных на удаление Соглашения об обмене ЭД, в которых используется обмен каталогами товаров.

Версия 1.1.5.1

Версия 1.1.5.1 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • Добавлены два состояния в регламент обмена электронными документами через оператора ЭДО - "Ожидается передача оператору" и "Ожидается отправка получателю".
  • Добавлен новый вид электронного документа - "Корректировочный счет фактура".
  • Реализован механизм визуализации структуры данных для формирования электронного документа через фиксированный макет, в котором на этапе разработки указываются названия полей электронного документа, их тип, обязательность заполнения, комментарии. На базе этого механизма переработано создание электронных документов "Соглашение об изменении стоимости (отправитель)" и "Соглашение об изменении стоимости (получатель)".
  • Обновлены подсистемы "Библиотеки стандартных подсистем" (БСП) до версии 2.1.3.22.
  • Исправлены выявленные ошибки.

Переход на версию 1.1.5.1 с версий 1.1.3.7, 1.1.4.2.

В этом разделе даны дополнительные сведения, которые требуется учесть при обновлении с версий 1.1.3.7, 1.1.4.2 на версию 1.1.5.1.

Добавлен новый вид электронного документа КорректировочныйСчетФактура.

Изменения в модуле ЭлектронныеДокументыПереопределяемый:

Необходимо переопределить вид электронного документа КорректировочныйСчетФактура в процедуре СписокТиповДокументовПоВидуЭД().
Процедура СоответствиеКодовРеквизитовИПредставлений добавлена - заполняет соответствие кодов реквизитов схем электронных документов их пользовательскому представлению.
В демо базе добавлен в обработку ЭлектронныеДокументы макет _ДемоПрикладноеПредставлениеРеквизитов для переопределения названий реквизитов при выводе сообщений об ошибке.
Функция ПодготовитьДанныеПоАкт501 переделана в процедуру.
Функция ПодготовитьДанныеПоСчетФактуре переделана в процедуру.
Функция ПодготовитьДанныеПоТорг12 переделана в процедуру.
Функция ПодготовитьДанныеПоТорг12Покупатель переделана в процедуру.
Функция ПодготовитьДанныеПоАкт501Заказчик переделана в процедуру.
Функция ПодготовитьДанныеПоНакладной переделана в процедуру.
Функция ПодготовитьДанныеПоСчету переделана в процедуру.
Функция ПодготовитьДанныеПоЗаказуТоваров переделана в процедуру.
Функция ПодготовитьДанныеПоОтветуНаЗаказ переделана в процедуру.
Функция ПодготовитьДанныеПоКаталогуТоваров переделана в процедуру.
Функция ПодготовитьДанныеПоПрайсЛисту переделана в процедуру.
Функция ПодготовитьДанныеПоАктуВыполненныхРабот переделана в процедуру.
Функция ПодготовитьДанныеПоОтчетуОСписанииКомиссионногоТовара переделана в процедуру.
Функция ПодготовитьДанныеПоПередачеТоваровМеждуОрганизациями переделана в процедуру.
Функция ПодготовитьДанныеПоВозвратуТоваровМеждуОрганизациями переделана в процедуру.
Функция ПодготовитьДанныеПоПлатежномуПоручению переделана в процедуру.
Функция ПодготовитьДанныеПоКорректировочномуДокументуПолучатель переделана в процедуру.
Методы ПодготовитьДанныеПоКорректировочномуДокументу и ЗаполнитьДанныеПоКорректировочномуДокументуПолучатель изменены.
В качестве данных для заполнения в метод передается не структура параметров, а дерево значений. В модуле ОбщегоНазначенияЭД находятся методы, позволяющие удобно заполнить дерево значений данными. Примеры заполнения данных методов приведены в демо базе.

Добавлены в обработку ЭлектронныеДокументы макеты _СоглашениеОбИзмененииСтоимостиОтправитель и СоглашениеОбИзмененииСтоимостиПолучатель, на основании которых формируется дерево значений для заполнения данными документа информационной базы.

Добавлен новый общий модуль ОбщегоНазначенияЭД.

Изменения в модуле ОбщегоНазначенияЭД:

Добавлена функция ДеревоДокумента - формирует дерево данных для заполнения прикладным решением.
Добавлена функция ЗаполнитьЗначениеРеквизитаВДереве - сохраняет значение в дереве данных.
Добавлена процедура ЗагрузитьТаблицуВДерево - записывает данные из таблицы значений в дерево значений.
Добавлена функция СтрокаДерева - возвращает строку дерева значений для заполнения в прикладном решении.
Добавлена процедура ДобавитьДопДанныеВДерево - добавляет данные из СтруктурыДанных в ДеревоЗначений.
Добавлена функция НазваниеКолонки - возвращает название реквизита из полного пути.

Версия 1.1.4.2

Версия 1.1.4.2 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • Исправлены выявленные ошибки.

Переход на версию 1.1.4.2 с версий 1.1.2.2, 1.1.3.7, 1.1.4.1.

В этом разделе даны дополнительные сведения, которые требуется учесть при обновлении с версий 1.1.2.2, 1.1.3.7, 1.1.4.1 на версию 1.1.4.2.

Изменения в модуле ЭлектронныеДокументыПереопределяемый:

Структуры заполнения данными документов информационной базы для формирования электронного документа изменены в следующих методах:
- ПодготовитьДанныеПоАктуВыполненныхРабот();
Ключ структуры Сумма заменен на ключ СуммаБезНДС.
Ключ структуры СуммаИтого заменен на ключ СуммаСНДСИтого.
- ПодготовитьДанныеПоНакладной();
Ключ структуры Сумма заменен на ключ СуммаБезНДС.
Добавлен ключ структуры Цена;
- ПодготовитьДанныеПоТорг12();
Ключ структуры Сумма заменен на ключ СуммаСНДС.
Ключ структуры СуммаИтого заменен на ключ СуммаСНДСИтого.
- ПодготовитьДанныеПоАкт501();
Ключ структуры Сумма заменен на ключ СуммаСНДС.
Ключ структуры СуммаИтого заменен на ключ СуммаСНДСИтого.
- ПодготовитьДанныеПоКорректировочномуДокументу().
Ключ структуры Сумма заменен на ключ СуммаСНДС.
Ключ структуры СуммаДоКорректировки заменен на ключ СуммаСНДСДоКорректировки.
При разборе электронных документов вида:
- ТОРГ12;
- АктВыполненныхРабот;
- ТитулИсполнителя;
- ТитулПродавца;
- СоглашениеОбИзмененииСтоимостиОтправитель;
Ключ СуммаБезНДС в дереве разбора заменен на Сумма.

Версия 1.1.4.1

Версия 1.1.4.1 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

Исправлены выявленные ошибки.

Переход на версию 1.1.4.1 с версий 1.1.2.2, 1.1.3.7.

В этом разделе даны дополнительные сведения, которые требуется учесть при обновлении с версий 1.1.2.2, 1.1.3.7 на версию 1.1.4.1.

Изменения в модуле ЭлектронныеДокументыПереопределяемый:

Функция ОпределитьИмяРеквизитаСуммы удалена.
Процедура ОпределитьСуммыВТаблицеДокументовНаПодпись добавлена.

Версия 1.1.3.7

Версия 1.1.3.7 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

Исправлены выявленные ошибки.

Переход на версию 1.1.3.7 с версий 1.1.1.3, 1.1.2.2, 1.1.3.5

В этом разделе даны дополнительные сведения, которые требуется учесть при обновлении с версий 1.1.1.3, 1.1.2.2, 1.1.3.5 на версию 1.1.3.7.

Изменения в модуле ЭлектронныеДокументыКлиентПереопределяемый:

Функция СопоставлятьНоменклатуруПередЗаполнениемДокумента переделана в процедуру.
Процедура ЗаполнитьИсточник перенесена в ЭлектронныеДокументыПереопределяемый.

Изменения в модуле ЭлектронныеДокументыПереопределяемый:

Функция ПолучитьЗначениеФункциональнойОпции удалена.

Изменения в модуле ЭлектронныеДокументы:

Добавлена функция ПолучитьЗначениеФункциональнойОпции - является интерфейсным методом получения значения функциональных опций библиотеки ЭД.

Изменения в регистре сведений ЖурналСобытийЭД:

- переименован реквизит СтатусЭД в УдалитьСтатусЭД;
- добавлен реквизит СтатусЭД с типом Перечисления.СобытияЭД.

Изменения в модуле ОбновлениеИнформационнойБазыЭД:

Добавлена процедура-обработчик обновления ОбновитьСтатусыЭДВЖурналеСобытийЭД для версии 1.1.3.7, который конвертирует в регистре сведений ЖурналСобытийЭД данные из реквизита УдалитьСтатусЭД с типом строка в реквизит СтатусЭД с типом Перечисления.СостоянияЭД.

В демо базе конфигурации БЭД добавлен стиль _ДемоОсновной. Рекомендуется использовать его в качестве основного стиля для конфигураций с основным режимом запуска "Обычное приложение".

Версия 1.1.2.2

Версия 1.1.2.2 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • Обновлены подсистемы "Библиотеки стандартных подсистем" (БСП) до версии 2.1.2.15.
  • Исправлены выявленные ошибки.

Переход на версию 1.1.2.2 с версий 1.1.0.4, 1.1.1.3

В этом разделе даны дополнительные сведения, которые требуется учесть при обновлении с версий 1.1.0.4, 1.1.1.3 на версию 1.1.2.2.

Изменения в модуле ЭлектронныеДокументыКлиент:

В функцию ОткрытьАктуальныйЭД добавлен новый параметр ПараметрыОткрытия = Неопределено;
Добавлена функция ПолучитьДокументыИБДляПередачиФНС - получает документы информационной базы по заданным критериям отбора.

Изменения в модуле ЭлектронныеДокументы:

Добавлена функция ПолучитьСоответствиеДокументамИБКомплектыЭлектронныхДокументов - получает соответствие документов информационной базы и комплекты актуальных электронных документов.

Версия 1.1.0.4

Версия 1.1.0.4 является новой редакцией продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

В состав библиотеки включены новые подсистемы:

Обмен с банками

  • Подсистема включает в себя функционал прямого обмена с банками платежными поручениями и выписками с использованием электронной цифровой подписи;

Обновление версий ИБ

  • Подсистема позволяет эффективно управлять обновлениями библиотеки;
    Новые возможности появились в подсистемах:

Электронные документы

  • Добавлен новый функционал по автоматизации "однократной сделки" с помощью электронных документов, позволяющий без предварительных настроек выгрузить или загрузить электронный документ по сделке;

  • Расширен функционал диагностики ошибок при обмене через оператора ЭДО для:
    а) процесса передачи и обработки электронных документов на стороне оператора ЭДО "Такском";
    б) проверки корректности настроек сертификатов криптографии и соглашений по использованию электронных документов.
  • Добавлена возможность прямого обмена электронными документами с контрагентами через FTP-ресурс;
  • Доработан функционал по обмену с "не-1С" системами, появилась возможность обмениваться через оператора ЭДО такими эл.документами: Акт, ТОРГ-12, Счет-фактура, произвольный электронный документ
  • Исправлены выявленные ошибки.

Переход на версию 1.1.0.4 с версий 1.0.x

В этом разделе даны дополнительные сведения, которые требуется учесть при обновлении с версий 1.0.х на версию 1.1.0.4.

Электронные документы

  • Удален реквизит Ответственный справочника СоглашенияОбИспользованииЭД.
  • Добавлены общие команды:
    • ВыгрузитьДокументВФайл;
    • ЗагрузитьДокументИзФайла;
    • ЗагрузитьПерезаполнитьДокументИзФайла;
8 (800) 50-50-257 и 8 (495) 63-62-977
Москва, ст. м. "Тульская", Варшавское ш., д.11, 2 этаж
wellsy-06


Скачать TeamViewer

Принимаем к оплате:


Производственный календарь
на 2017 год

Узнайте первыми об акциях и скидках, получайте свежие новости и полезные материалы по продуктам 1С еженедельно!

Наверх